[Mono-list] Built GTK, GTK-SHARP and MONO from SVN - issue running MONO applications

Brett Senior brett_senior at yahoo.com.au
Sat Feb 28 23:30:52 EST 2009

Yesterday I fetched the latest versions of GTK and
GTK-SHARP from SVN and built them. All seemed to go OK and files
installed in various directories under /opt/mono. I keep GTK etc in
here to keep in separate from my 'system' GTK.  
Today I fetched MONO from SVN and it also compiled fine.  Again it went into /opt/mono so that I keep it separate from my system MONO.

I am running Debian/Squeeze on a 64 bit machine and previous SVN builds have not caused me any problems. 

However, today when I try to run any mono applications they freeze
and do not start up at all. When I ran mono --trace on one of them it
goes OK until it hits the following: 

[0x7f2ea8f1c720: 3.49731 6] ENTER: (wrapper managed-to-native)
(intptr,intptr,int,int,intptr&)(0x1b05910, 0x1a0c2e0, 16, 0,
[BYREF:0x7fffb0f38c18], ) 

which seemed to indicate an issue with either GTK or GTK-SHARP or MONO - so I have posted to both lists as I don't know which is more appropriate for the above problem.

I am running version 22426 of GTK, version 128288 of GTK-SHARP and version 128288 of MONO . 

I do a make clean before each build and have also tried a make uninstall and then another make install to no avail. 

Any help would be much appreciated as I am unable to run my
development environment MonoDevelop which depends on GTK, GTK-SHARP and MONO.
Brett Senior.

      Stay connected to the people that matter most with a smarter inbox. Take a look http://au.docs.yahoo.com/mail/smarterinbox
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20090228/38388682/attachment.html 

More information about the Mono-list mailing list