[Mono-list] Mono Installation on Sparc

Tynar ripper33 at gmail.com
Mon Sep 22 03:51:07 EDT 2008

Hello all,
First of all I thank all developers. I am good .Net developer but new to
Unix. I am in troubles with Mono installation. If would really appreciate if
someone helps me with installation. I believe that I have a new and clean
installation of Solaris 10, libgdiplus, glib-2.0, pkgconfig-0.18, gcc3utils.
But I was not able to make mono and couldn't understand why? Firstly I
installed all the required codecs(png, gif) for libgdiplus with pkg-get

uname -a
SunOS Host 5.10 Generic_127127-11 sun4u sparc SUNW,Sun-Blade-1500

echo $PATH


        mcs source:    $(top_srcdir)/mcs
        olive source:

        GC:          included
        TLS:         pthread
        SIGALTSTACK: yes
        Engine:      Building and using the JIT
        2.0 Beta:    yes
        2.1 Alpha:   yes
        JNI support: IKVM Native
        libgdiplus:  assumed to be installed
        zlib:        system zlib
        oprofile:    no

cc1: error: invalid option `t'
gmake[3]: *** [mono-hash.lo] Error 1
gmake[3]: Leaving directory `/opt/mono2/mono-1.9.1/mono/utils'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/opt/mono2/mono-1.9.1/mono'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/opt/mono2/mono-1.9.1'
gmake: *** [all] Error 2

I tried many ways, searched forums blogs (Jonel's), but couldn't find
solution yet. I looked mono build log tried that way but nothing else. I
would thank if someone could write to-do list for newbies on Unix as the
mono-project.com documentation has less info for newbies.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20080922/6c6a298a/attachment.html 

More information about the Mono-list mailing list