[Mono-list] Looking for advice on accessing MySQL database

TraLou louis at traglobal.com
Thu Oct 30 17:27:30 EDT 2008

I have just started working with Mono using the 2.0.1 VMWare openSUSE 11.0
Image.  I have gone through the basics and now want to try one of my
applications on Mono.  It's a simple console app and when I run it through
Moma everything checks out.

I copied the executable and MySQL.Data.dll over to openSuse and set up the
shell script as recommended.  When I launch my app everything works right up
until Open() is called on the MySQLConnection object.  It then throws an
exception and states that it could not connect to any of the MySQL

I have tried with MySQL.Data.dll versions 5.1.7 and 5.2.3. My connection
string looks like the following:

Database=dbname;Data Source=hostIp;User
ID=user;Password=password;Pooling=false;Connection Timeout=10;

I tried also adding Protocol=socket;Port=3306; as recommended on someone's
blog but no luck there.

The MySQL database is on my dev machine that the VM is running on.  I can
ping from the VM to the host with no issues and I can access MySQL remotely
from my application on another Windows machine using the same credentials.

I'm sure that a ton of people must be using MySQL so I'm hoping that I'm
just missing something simple.
View this message in context: http://www.nabble.com/Looking-for-advice-on-accessing-MySQL-database-tp20255843p20255843.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list