[Mono-list] Windows Registry implementation

chairao crao at bandl.com
Fri Oct 3 16:19:51 EDT 2008

Never mind. It was a LINUX security thing. I just ran the installer program
under root and it all worked.

chairao wrote:
> When I tried to create a registry entry (that did not exist), a
> SecurityException of "No Access to the given key" was thrown by Mono. My
> own application's installer is a .NET program which creates the Registry
> entries that I need. This is a fundamental part of my application (the
> Registry that is). 
> On the openSUSELINUX 11.0 which I installed, I am not clear where the
> Registry (values.xml) files are supposed to reside. Under Fedora with Mono
> installed, I could create the registry files quite easily. What am I
> missing under openSUSE LINUX 11.0 ? 
> I found a copy of the Microsoft.Win32.UnixRegistryApi class online, and it
> was throwing the exception when it was attempting to do a CreateDirectory
> (I presume for the Registry directory where the values.xml is to be
> placed). 
> chairao wrote:
>> Which level of Mono has the Windows Registry classes of .NET been
>> implemented ? Does it exist in Mono 1.9 ?

View this message in context: http://www.nabble.com/Windows-Registry-implementation-tp19803042p19804880.html
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list