[Mono-list] System.DllNotFoundException: gdiplus.dll - libgdiplus.so is Missing on CentOS 5.1 / WHM (cPanel)

Chris Morley g18c at hotmail.com
Mon Jul 14 17:28:59 EDT 2008

Thanks for the reply, but the more I think about installin libgdiplus via yum the less happy I am.

 Should libgdiplus be installed by default and alongside in the same package when installing mono? Im concerned why mine was missing with installing mono via Easy::Apache WHM cPanel script.

 Furthermore I read on this mailgroup archives that the versions of libgdiplus and mono should be the same versions, this is not the case as my mono installed is 1.9 and the lib 1.0.5!



 -----Original Message-----
 From: Valentin Sawadski <valentin.sawadski at googlemail.com>
 Sent: 15 July 2008 00:59
 To: g18c at hotmail.com
 Cc: mono-list at lists.ximian.com
 Subject: Re: [Mono-list] System.DllNotFoundException: gdiplus.dll - libgdiplus.so is Missing on CentOS 5.1 / WHM (cPanel)


  On Mon, 2008-07-14 at 13:48 -0700, g18c wrote:
  > g18c wrote:
  > >
  > > I'm not supprised its failing given the above file is missing, but my
  > > question relates to resolving this in a WHM installed environment. Am i
  > > better to remove mono in Easy::Apache and install this manually via 'yum',
  > > or are there other options for getting libgdiplus.so onto my system?
  > >
  > Sorry for the slightly premature post, i installed libgdiplus via 'yum
  > install libgdiplus', i now have the following installed on my CentOS 5.1
  > box:
  > root at host [/usr/local/lib]# find / -name libgdiplus*
  > /var/cache/yum/dag/packages/libgdiplus-1.0.5-1.2.el4.rf.i386.rpm
  > /var/cache/yum/dag/headers/libgdiplus-1.0.5-1.2.el4.rf.i386.hdr
  > /usr/lib/libgdiplus.so.0.0.0
  > /usr/lib/libgdiplus.so.0
  > /usr/share/doc/libgdiplus-1.0.5
  > However when i run:
  > root at host [/usr/local/lib]# ldconfig -p |grep libgdiplus
  >         libgdiplus.so.0 (libc6) => /usr/lib/libgdiplus.so.0
  > I can see the lib is linked, but i still get same
  > 'System.DllNotFoundException: gdiplus.dll' exception.
  > Any pointers much appreciated.

  Try looking at http://mono-project.com/DllNotFoundException and
  especially http://mono-project.com/Config_DllMap

  Hopefully this might help :-)

  Kind Regards,

More information about the Mono-list mailing list