[Mono-list] Mono 1.9 on CentOS 5 (RHEL 5)

Lyle - CosmicPerl.com Support webmaster at cosmicperl.com
Wed Apr 16 07:32:21 EDT 2008

Hi All,

 I got mono working without much more than installing the CentOS RPM's. 
This worked great until I wanted VB and couldn't find an RPM for the 
right version.
In my searching I came across Novell's repository which appeared to have 
RPM's for the latest version 1.9 for almost all the Linux distributions:-

Brilliant I thought... Removed the old RPM's, installed the new ones, 
everything was looking great. There seemed to be no mod_mono.conf for 
apache with this new lot, so I used the old one I'd backed up that come 
with the native CentOS RPMs.

Apache started fine, all seemed great.. Until I tried loading the 
examples which I had aliased to /net-examples which loaded but none of 
the links worked, it appeared a / was missing as each example linked to 
/net-examples1.1 rather than /net-examples/1.1. Being a Perl programmer 
I looked through the index.aspx file and battled my way through the c# 
code. Finally I realised that it was a problem with SiteMapReader which 
I commented out, making it default back to the old display code (which 
was still in the file) which worked a treat. Stylesheet didn't load, but 
then that was pointing to / rather than /net-examples... aghhhh! 
Regardless I was happy that c# was working even if the latest version of 
the examples had some weird layout problems.

Leaving the examples I uploaded some .aspx files to my apache 
public_html folder. Now when I try to load them in my browser I get 404 
errors.. Strange as they worked before with the CentOS RPMs, and the 404 
error I was getting wasn't apache's it was mono's (well xsp I guess). So 
apache must have been passing the call to XSP, which in turn was loosing 
it? Error page's main message is "Server Error in "/" Application". No 
wonder it can't find it if it's looking for just "/" rather than the 
file name, but apache must be passing it over as it working with the old 
verion... aghhhhhhh!!!!

Needless to say I've lost some hair over this today. I've resulted to 
removing all the new RPMs, re-installing the ones from CentOS and 
compiling the right version of VB from source. Which is working.. But 
I'd prefer to be on the latest version and be using RPMs for everything 
for ease of future updates.

Why did I have so many problems with the Novell ones?? Is there a big 
fat readme file I'm missing?

I hope I posted this to the right place, if not please point me in the 
right direction.



More information about the Mono-list mailing list