[Mono-list] Problem with asp.net 2.0 after upgrading to 1.2.4

Julien Sobrier julien at sobrier.net
Thu Jul 5 23:36:54 EDT 2007

Julien Sobrier wrote:
> Julien Sobrier wrote:
>> Hello,
>> I upgraded mono from 1.1.17 to 1.2.4. I had a small web application taht
>> was running fine on the older version, but not with 1.2.4:
>> 1/ when there is a compilation error, I dont get the name of the
>> original file that fails, but only the name of the temporary ASP file,
>> and without the source code displayed. I only get something like this:
>> /tmp/username-temp-aspnet-0/8a6305a0/402057a0._0.cs(51,13) : error
>> CS0103: [...]
>> 2/ the home page does not compile anymore. It is split into 2 files
>> (patial classes): default.aspx contains the HTML and Web controls,
>> App_Code/Default.cs contains the c# code. In the aspx page,I have a
>> treeview control: <asp:TreeView ID="SourceTree" runat="server" />
>> I use this treevew in the cs file:
>> protected void Page_Load(object sender, EventArgs e)
>> {
>>  [...]
>>     SourceTree.Nodes.Add(newNode);
>> But at compilation time, mono complains that SourceTree does not exist.
>> Is there something taht I should do differently in 1.2.4?
>> Thank you
>> Julien
> BTW, for 2/, I forgot to mention that if I add "protected TreeView
> SourceTree;" in App_Code/Default.cs, I get:
> error CS0102: The type `_Default' already contains a definition for
> `SourceTree'

For 1, it actually depends on the type of error.

for 2, I have no clue. I tried the example given at
and I run against the same problem.

I don't use XSP2 or mod_mono to start the web server, but this piece of

XSPWebSource source = new XSPWebSource(System.Net.IPAddress.Any, 8080);
server = new ApplicationServer(source);


More information about the Mono-list mailing list