[Mono-list] Nothing happens with mono-service and EventLog.WriteEntry

Michael Schurter michael at susens-schurter.com
Mon Feb 12 13:50:39 EST 2007

On Mon, 2007-02-12 at 10:42 -0600, Michael Schurter wrote:
> I created a service in MonoDevelop, compiled it using the 2.0 profile,
> and run it using mono-service.
> Everything appears to work fine: Service started and stopped messages
> show up in my syslog, the process is running, and the lock file exists.
> However my service doesn't seem to do anything, and none of my
> EventLog.WriteEntry() calls seem to generate any logging information (I
> also tried Console.WriteLine()).

Attached is a simple service template that should make a good test case.
On my computer the only output I get is in my syslog:

Feb 12 12:39:56 schurter3-linux mono: ServiceTemplate.exe: Service
ServiceTemplate started
Feb 12 12:40:36 schurter3-linux mono: ServiceTemplate.exe: Stopping
service ServiceTemplate

Those are automated messages and none of my EventLog.WriteEntry()s seem
to work.  I've tried running my service with mono-service and

I still can't figure out how to get good debugging information.  Adding
--trace just floods me with output, and when I add filters like
"--trace=-N:System.XML,-N:System.IO" mono just exits immediately.

I'm really stuck...  anyone have any ideas?

Michael Schurter
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ServiceTemplate.zip
Type: application/zip
Size: 6242 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/mono-list/attachments/20070212/8b349602/attachment.zip 

More information about the Mono-list mailing list