[Mono-list] Mod_mono: Win32 IO returned ERROR_NO_MORE_FILES (was RE: Problem with files in apache-temp-aspnet-0)

Kevin Flanagan kevin.flanagan at bom.co.uk
Sun Dec 9 16:15:49 EST 2007

It might well be the same problem in fact, Nicola - stopping tmpwatch
running hasn't helped. So, I figured I'd tried upgrading from 1.2.4 to

That causes a different problem - the site won't run at all (500 Internal
Server Error). Looking at error_log, this seems to be where things go wrong:

System.IO.IOException: Win32 IO returned ERROR_NO_MORE_FILES. Path:
  at System.IO.Directory.GetFileSystemEntries (System.String path,
 pattern, FileAttributes mask, FileAttributes attrs) [0x00000]
  at System.IO.Directory.GetFiles (System.String path, System.String
pattern) [0
  at System.IO.DirectoryInfo.GetFiles (System.String pattern) [0x00000]
  at (wrapper remoting-invoke-with-check) System.IO.DirectoryInfo:GetFiles
  at Mono.WebServer.ModMonoWorker.CheckDirectory (System.IO.DirectoryInfo
  at Mono.WebServer.ModMonoWorker.GetOrCreateApplication (System.String
vhost, I
nt32 port, System.String filepath, System.String virt) [0x00000]
  at Mono.WebServer.ModMonoWorker.InnerRun (System.Object state) [0x00000]
  at Mono.WebServer.ModMonoWorker.Run (System.Object state) [0x00000]
[Sun Dec 09 21:00:35 2007] [error] (70014)End of file found: read_data
[Sun Dec 09 21:00:35 2007] [error] Command stream corrupted, last command
was -1

Reverting back to 1.2.4, everything works fine.

Anyone know what the problem might be here?


-----Message d'origine-----
De : Nicola Dell'Amico [mailto:webring at ndatech.it]
Envoyé : 07 December 2007 07:26
À : Kevin Flanagan
Cc : mono-list at lists.ximian.com
Objet : Re: [Mono-list] Problem with files in apache-temp-aspnet-0

Kevin Flanagan wrote:
> Bah - suppose this kind of thing is only to be expected moving from one
> distro to another. Yes, tmpwatch was set to run daily on /tmp. Stopping
> seems likely to sort it.
> Thanks.
> Kevin.
> -----Message d'origine-----
> De : Marek Habersack [mailto:grendello at gmail.com]
> Envoye : 06 December 2007 22:22
> A : Kevin Flanagan
> Cc : mono-list at lists.ximian.com
> Objet : Re: [Mono-list] Problem with files in apache-temp-aspnet-0
> On Thu, 6 Dec 2007 22:13:56 -0000, "Kevin Flanagan"
> <kevin.flanagan at bom.co.uk>
> scribbled:
>> Environment: Mono 1.2.4, mod_mono 1.2.4, Fedora Core 5, ASP.NET 1.1,
>> Apache/2.2.2 running virtual domains configured with Plesk 8.2.0 and
>> autohosting with mod_mono.conf
> [snip]
>> Bottom line is, what's going on with the compiled files, and why do I end
> up
>> with that error page?
> My guess is you have a cronjob which periodically (once a week?) cleans up
> your /tmp directory and its subdirectories. Hunt around /etc/cron* for
> clues.
> best regards,
> marek
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

Hi Kevin,

I hope you have solved but It sounds like the issue I coped with some
time ago.
I opened a bug (https://bugzilla.novell.com/show_bug.cgi?id=324783) for
that and now it seems to be fixed on rev
I haven't tested yet. I 'm still on rev, which works
fine for me .... it seems an issue with rev 1.2.4 and, FC5, Apache 2.2.2
... your configuration and mine seems look like the same.

In my test case rev works fine while 1.2.4 gives the error, and
without any modification to cron jobs.



More information about the Mono-list mailing list