[Mono-list] Problems with Visual Studio 2005 compiled code

Eric Morgan eric at rengeo.com
Wed Aug 29 17:08:50 EDT 2007

Hey all,

So, my problems may seem tenfold, but here we go.  Our company was having
memory issues because the address space isn't big enough on 32bit.  Our app
can easily eat more than 2-4gb of memory because of some of the heavy
computations we use are on VERY large sets of data.  In both .NET and Mono,
this would cause an out of memory exception to be thrown externally and the
program just shuts down.  On windows, this problem was solved by building
the code for a 64bit processor with Visual Studio 2005.  We hacked the code
up real quick and used a trial version.  We bought Visual Studio 2005 to
help make that more permanent.  Long story short:

Code compiled from VS2005 does not run under mono.  It says that it cannot
open the assembly (Main executable).  The same mono version will run other
apps compiled with our old VS2003.  Is there some configuration option I'm
missing? What else can I do to troubleshoot it to at least see what's wrong?

My environment:
RHEL 4 (guest) running under VMWare workstation 6
Mono JIT compiler version 1.2.5, /trunk/ r84470
MoMA report for 1.2.4 compatibility showed no errors and did not complain
that it wasn't a valid .NET assembly
All .dll and .exe have rx permissions.

Compiling for Any CPU (x64 failed so I changed it hoping that would work.
No DEBUG/TRACE constants defined.
code NOT optimized.

I've tried forcing the runtime to use 2.0 with --runtime=v2.0.50727 (the
output below is with that option.  Same results without).
I've tried the MONO_LOG_LEVEL and --trace options.  Neither really show
anything.  Output below:

Mono-INFO: Assembly Loader probing location: '/home/rengeo/RenegadeGeophysic
Mono-INFO: Assembly Loader probing location:

Mono-INFO: Image addref mscorlib 0x718c90 ->
0x715400: 2

Mono-INFO: AOT failed to load AOT module
cannot open shared object file: No such file or directory

Mono-INFO: Assembly Loader loaded assembly from location:
Mono-INFO: Config attempting to parse:

Mono-INFO: Config attempting to parse:
Mono-INFO: Config attempting to parse:
Mono-INFO: Assembly mscorlib 0x718c90 added to domain SeismicStudio.exe,

Mono-INFO: Config attempting to parse:
Mono-INFO: Config attempting to parse: '/home/rengeo/.mono/config'.
Mono-INFO: Assembly Loader probing location:

Mono-INFO: Unloading image
Cannot open assembly

Mono-INFO: Unloading domain SeismicStudio.exe 0x2a983d2e00, assembly
mscorlib 0x718c90, refcount=1

Mono-INFO: Unloading assembly mscorlib [0x718c90].
Mono-INFO: Unloading image
[rengeo at localhost bin]$

Thank you for any help!

Eric Morgan
Renegade Geophysics
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20070829/b11432c7/attachment.html 

More information about the Mono-list mailing list