[Mono-list] Mono crash on latest SUSE 10.1 install

Ben Clewett ben at roadrunner.uk.com
Fri Sep 29 08:35:35 EDT 2006

For somebodies information:

There is (probably) a bug in the latest SUSE 10.1 release of 
mono/libgdiplus as shown below.  This is a brand new installation with 
no modifications.


I have tried upgrading libgdiplus to, same error.

I hope this is useful to somebody....

Apache error log as follows:

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.


in (wrapper managed-to-native) System.Drawing.GDIPlus:GdipDisposeImage 
(intptr) <0x4>
in (wrapper managed-to-native) System.Drawing.GDIPlus:GdipDisposeImage 
(intptr) <0xffffffd8>
in System.Drawing.Image:DisposeResources () <0x10>
in System.Drawing.Image:Dispose (bool) <0x13>
in System.Drawing.Image:Finalize () <0x10>
in (wrapper runtime-invoke) System.Object:runtime_invoke_void 
(object,intptr,intptr,intptr) <0x51c57456>

Native stacktrace:

         /usr/bin/mono(mono_handle_native_sigsegv+0xbb) [0x8150bab]
         /usr/bin/mono [0x811fe80]
         /usr/lib/libgdiplus.so(GdipFree+0x1d) [0xb645437d]
         /usr/lib/libgdiplus.so(gdip_bitmap_dispose+0x2f) [0xb644fdbf]
         /usr/lib/libgdiplus.so(GdipDisposeImage+0x169) [0xb6468359]
         /usr/bin/mono [0x8153507]
         /usr/bin/mono [0x81123d1]
         /usr/bin/mono [0x8153685]
         /usr/bin/mono [0x80b4154]
         /usr/bin/mono [0x80fd38e]
         /usr/bin/mono [0x8115e35]
         /lib/libpthread.so.0 [0xb7ed734b]
         /lib/libc.so.6(__clone+0x5e) [0xb7e4165e

More information about the Mono-list mailing list