[Mono-list] monodevelop on FC5 doesn't find assembly gtk-sharp]

enzo enzo.arlati at libero.it
Mon Oct 9 16:00:00 EDT 2006

Altough my question is about monodevelop, I post the question also on 
this mono list, because I suppose the problem I got is somewhere due to 
configuration problem.
I' m a newby on mono and I tried to install monodevelop to ease the 
learning process but I think there is something wrong inside the 
configuration, mybe there should be some old assembly somewhere, which I 
should not be able to find.

I'm trying to use monodevelop 0.12 on FC5 .
The installation where performed using yum, all dependencies are 
resolved properly but when I run monodevelop I got this error:

enzo at enzo5 tmp]$ monodevelop

** (./MonoDevelop.exe:5401): WARNING **: The following assembly 
referenced from /usr/lib/monodevelop/bin/gnome-sharp.dll could not be 
     Assembly:   gtk-sharp    (assemblyref_index=2)
     Public Key: 35e10195dab3c99f
The assembly was not found in the Global Assembly Cache, a path listed 
in the MONO_PATH environment variable, or in the location of the 
executing assembly (/usr/lib/monodevelop/bin).

** (./MonoDevelop.exe:5401): WARNING **: Could not load file or assembly 
'gtk-sharp, Version=, Culture=neutral, 
PublicKeyToken=35e10195dab3c99f' or one of its dependencies.
2006-10-06 22:33:00,418 [-1209149760] ERROR 
MonoDevelop.Core.ILoggingService [(null)] - Add-in failed to load: 
2006-10-06 22:33:00,477 [-1209149760] ERROR 
MonoDevelop.Core.ILoggingService [(null)] - 
System.Reflection.ReflectionTypeLoadException: The classes in the module 
cannot be loaded.
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000]
  at MonoDevelop.Core.AddIns.DefaultAddInTree.LoadCodonsAndConditions 
(System.Reflection.Assembly assembly) [0x00000]

the libraries gtk-sharp and gnome-sharp , which seems to cause the 
problem are installed in GAC, tough I have revisions 1.0 and 2.8 while 
monodevelop seems to require the revision 2.0.

[enzo at enzo5 varie]$ gacutil -l | grep -i gtk-sharp
gtk-sharp, Version=, Culture=neutral, PublicKeyToken=35e10195dab3c99f
gtk-sharp, Version=, Culture=neutral, PublicKeyToken=35e10195dab3c99f

[enzo at enzo5 varie]$ gacutil -l | grep -i gnome-sharp
gnome-sharp, Version=, Culture=neutral, 
gnome-sharp, Version=, Culture=neutral, 

Does someone give me more hints on how to solve or better investigate on 
such problem ?
Regards, Enzo

REPLY TO: perl -e 'print qq^VVCWCQJUVD00YQVWKVBPG^^qq^3898m08970Yp584299l93^ '
      SKYPE username: earlati
trusted computing,  who is it ? -->  http://www.p2pforum.it/counter/click.php?id=21 

More information about the Mono-list mailing list