[Mono-list] mod_mono Permissions Error

cdlaforc cdlaforc at centurytel.net
Thu Oct 5 09:44:25 EDT 2006

cdlaforc wrote:
> Gonzalo Paniagua Javier-4 wrote:
>> On Wed, 2006-10-04 at 11:09 -0700, cdlaforc wrote:
>>> I have recently installed all the mono packages from
>>> http://go-mono.com/download-stable/fedora-5-i386/ and have been trying
>>> to
>>> look at some of the example.  I have gotten the xsp server working to
>>> view
>>> the example, but in my attempts to get the mod_mono apache module to
>>> work I
>>> am receiving 503 service errors.  Here are the lines from my error_log:
>>> /usr/lib/pkgconfig/../../bin/mod-mono-server: line 2: /usr/bin/mono:
>>> Permission denied
>>> /usr/lib/pkgconfig/../../bin/mod-mono-server: line 2: exec:
>>> /usr/bin/mono:
>>> cannot execute: Permission denied
>>> I tried to remove the /tmp/.wapi dir as said in another post I have seen
>>> and
>>> I restarted httpd but it didn't work.  Let me know if you can offer me
>>> any
>>> help on that.
>> Looks like the package for mod_mono has not been updated.
>> -Gonzalo
>> _______________________________________________
>> Mono-list maillist  -  Mono-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-list
> I think I had gotten that update yesterday.  I ran the update this morning
> just to make sure, but mod_mono was not one of the packages and I am
> having the same problems.  Any other ideas?  Could this be Selinux causing
> problems?
> Thanks,
> Chris.

So I stayed with my selinux thought and found this line to disable selinux
for the httpd dameon:
   setsebool -P httpd_disable_trans 1
and restarted httpd
   service restart httpd
and now it works fine.  I don't know if this is the best solution, but let
me know if anyone has anything better.


View this message in context: http://www.nabble.com/mod_mono-Permissions-Error-tf2384014.html#a6658794
Sent from the Mono - General mailing list archive at Nabble.com.

More information about the Mono-list mailing list