[Mono-list] How to run mono in kubuntu

Andrus kobruleht2 at hot.ee
Sun Nov 12 09:32:03 EST 2006

>> ./mono   anystring
> Step one : write a program myProgram.cs using C# language
> Step two : compile it : mcs myProgram.cs
> Step three : execute it : mono myProgram.exe

mono myProgram.exe

gives exactly the same result: nothing happens, characters entered from
keyboard are echoed in screen.
I created also icon in KDE desktop. After clicking to this icon KDE shows
loading icon. After some time icon disappers and nothing happens.
myProgram.exe is compiled with VCS in Windows.
In Windows it works OK.

MONO works in my kubuntu a number of months but yesterday suddely it stops
working and I have no idea why.
"MONO anystring" result shows that problem is not in my application.

I use Linux binary installer packages.
I uninstalled mono and installed 1.2RC0 but the problem presists.
I tried to run mono myapp.exe with --debug, -v and --trace swithes but this
nothing is printed to console.
mono -V works OK.

I have little Linux and Mono knowledge.
I'm afraid that when I distribute my application in Linux and users will
encounter the same issue I'm unable to help them and thus is is not possible
to support mono application in Linux.

Any idea ?


More information about the Mono-list mailing list