[Mono-list] Apache and Mono - 403 Access Forbidden

Bradley, Peter PBradley at uwic.ac.uk
Mon Jan 30 05:57:18 EST 2006



I'm trying to get my ASP.NET program to run on Apache2 on SuSE 9.3 Pro,
but I get a 403 Access Forbidden error.  I'm using the latest version of
Mono (1.1.13.) downloaded and updated via Red Carpet.


The program runs fine on XSP on its default port (8080).


Apache is installed successfully.  If I type in http://localhost
<http://localhost/>  (or the external url if I'm not on the LAN) I get
the Apache default page.


I've configured Apache following the instructions given at:




Apart from the additions to http.conf set out in the link above, my
configuration file is the Apache default.


Trying to access http://localhost/AspNetOnApache (as in the link above)
gives a 403 error.


I've also tried the following:

*	Copy the application folder (MSc) into the Apache default folder
(/srv/www/htdocs) and try to access it using the url

	*	Gives the same (403) error

*	Comment out the "Deny all" instruction in the default config
file and restart Apache.  Still get the same error, so put it back.
*	Create a folder (peter) under /srv/www/htdocs and copy the
Apache default html page (index.html.en) into it

	*	Rename the copied file to index.html
	*	Try to access the new file using the url

		*	This works without any problem, so file
permissions in the Apache virtual directory trees don't seem to be the


So it looks as though the problem is with accessing Mono.


Any ideas?


Thanks in advance.





-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-list/attachments/20060130/7fcc5d38/attachment.html

More information about the Mono-list mailing list