[Mono-list] Service problem

Andreas Färber andreas.faerber at web.de
Tue Feb 28 17:19:44 EST 2006

Sorry, I posted a few minutes too early ... it's solved now.

mono-service2 was a valid point, I do need it. But I was also lacking a
referenced assembly when testing it with my home-made mono-service2, so
that it crashed once that assembly was referenced.

Please add mono-service2 to the packages asap.

For anyone facing similar problems with Services: On Fedora to see
mono-service's output type: mono /usr/lib/mono/{1|2}.0/mono-service.exe


Andreas Färber schrieb:
> Okay, I'm a step further now and have found out that I should use
> *mono-service2* because I am compiling with gmcs.
> Unfortunately neither the official FC4 package nor the Blastwave Solaris
> package include this, so I've compiled it manually from SVN, derived a
> wrapper script and copied both to their respective places. Is this file
> new or is this a packaging problem?
> This time with mono-service2 I am really not seeing any response from
> the server in the trace.
> The client still receives a zero length response, and the server is gone
> afterwards without any error message in /var/log/messages. And if I run
> the same server class as a console app it works.
> Noticing in monoservice.cs that Syscall.syslog is used for logging I
> have also eliminated all Console.Error.WriteLine calls, but no change.
> Any help appreciated!
> Andreas

More information about the Mono-list mailing list