[Mono-list] mod_mono and xsp have different versions

jsnow50 nettech29 at verizon.net
Thu Aug 24 22:15:26 EDT 2006

I keep getting the error message: "mod_mono and xsp have different versions"
when attempting to run mod-mono-server.  I am able to run XSP fine, but as
soon as I try to run mod-mono-server (I am trying to run mod-mono server to
see why it is not working in apache), as soon as I try to navigate to my
xsp's server webpage, I keep getting the different versions error.  

I had mono running fine using the rpm packages that came with Fedora.  I am
running some things that require the latest version of mono, so I attempted
to upgrade.  I am not sure if it was at this point or later that I tried
installing the latest version of mono by compiling it (this may have
something to do with my problem).  I uninstalled the compiled version of
mono and then installed the latest fedora mono rpms (from the mono website)
using Yum by placing the mono.repo file in the yum.... directory.  I kept
receiving this error so I tried removing all of the packages related to
mono.  I then searched for any file related to mono or xsp and deleted them
too.  I then tried downloading the zip file containing all of the mono
components and installing them.  After this attempt I received the same
error.  I checked the version of mono, mod-mono-server, and xsp and they
were all version:  I have since tried to downgrade my version of
mono to the latest stable release.  This produces the same error.  I have
know idea what is causing this error.  Someone please help.  

-Fedora Core 5 (2.6.17-1.2174_FC5)
-Selinux disabled 

View this message in context: http://www.nabble.com/mod_mono-and-xsp-have-different-versions-tf2162406.html#a5976340
Sent from the Mono - General forum at Nabble.com.

More information about the Mono-list mailing list