[Mono-list] Trouble with Mod_Mono and Apache 2

Jeff Northrop Jeff Northrop <jnorthrop@gmail.com>
Sun, 8 May 2005 18:07:06 -0400

I'm fairly new to Linux and new to Mono so forgive me if this has an
easy answer. I've installed Apache 2, Mono 1.1.7 and XSP 1.0.9, and
Mod_Mono 1.0.9 on a Fedora Core 3 installation. Apache works fine, XSP
runs my asp.net pages fine but mod_mono and apache do not want to play
nice together.
The error I'm receiving is 503 - Service Temporarily Unavailable. I've
searched around and found that most people were having problems with
permissions on their /tmp directory. I've tried the following, none
have helped:

- I ran chmod -R 777 /tmp.
- I deleted the .wapi directory.
- I ran mod_mono_server from the command line and ran chmod 666 on
- I set the user and group in the httpd.conf file to nobody and nogroup.
- I set the MonoUnixSocket and MonoWapiDir explicitly

After each attempt I restarted apache.

I have the mod_mono.conf file in the /etc/httpd/conf.d directory with
the following line:
LoadModule mono_module /usr/lib/httpd/modules/mod_mono.so
And the following lines in my httpd.conf file
Include conf.d/*.conf
    ServerAdmin webmaster@gfgdgdgfd.com
    DocumentRoot /var/www/docs/leveledlist
    ServerName leveledlist
    ErrorLog logs/leveledlist-error_log
    CustomLog logs/leveledlist-access_log common
   Alias * "/var/www/docs/leveledlist"
   MonoApplications "/:/var/www/docs/leveledlist"
   SetHandler mono

I'm at a loss. Any advice is appreciated.