[Mono-list] Monodevelop problems

Vince Jennings v.jennings@ntlworld.com
Sun, 01 May 2005 17:27:50 +0100

I'm new to linux and mono, currently using C++ in windows, but I'm 
impressed with C# and the possibilites presented by the mono framework. 
However, having spent three days trying to get monodevelop working I am 
now stuck and need advice which I have not been able to find anywhere else.

I've tried two distributions of linux - Mandrake 10.1 and Fedora 3. On 
both I have successfully installed mono itself and can build and run 
basic console "Hello World" applications from the command line, but my 
problem lies with monodevelop.

On Mandrake I used the binary installer for all distributions and this 
installed ok, and monodevelop compiles the console app with a '1 
succeeded, 0 warnings' message, but when I click build it gives a '0 
succeeded, 0 warnings' message (nothing else) and doesn't produce any files.

On Fedora3, I downloaded all the recommended RPM's for Fedora3 and used 
the Package Installer (having laboriously worked out the order in which 
the 23 files had to be installed by trial and error) and they all seemed 
to install ok. I did try the Red Carpet route as suggested, and even 
went so far as downloading the 470Mb of Zenworks to get it, only to find 
that it wouldn't install because of a missing key, hence the above.

Once again I can build and run the basic console app, but I can't even 
find monodevelop anywhere on the system! Where is it? Checking the 
Package Installer again for monodevelop says it's already installed. 
Searching the root for monodevelop lists no files found. Typing 
'monodevelop' on the command line gives unknown command.

This is probably due to my ignorance of linux, but any help would be 
appreciated to get me going :)