[Mono-list] Mono Installation Question

Daniel Lopez daniel at rawbyte.com
Wed Jun 29 03:23:09 EDT 2005

Hi Kent,

I think RHAS is too old for the RH9 RPMs and the installer (which is based
on the RedHat RPMs) since it seems they reguire a newer version of glibc and
libgmodule than  is available on your system. Have you tried compiling from source?
You may still not have access to GUI development, but the server side of
things should be fine

Best regards


On Wed, Jun 29, 2005 at 05:01:55PM +0930, Kent Boogaart wrote:
> Hi there,
> I need some help installing Mono on a Redhat Advanced Server release 2.1AS
> system. I'm pretty much a linux noob so please "speak slowly" for me :)
> The first thing I tried was the installer for x86. The installation went
> smoothly. However, when I tried to run mono I got:
>         mono: error while loading shared libraries: libgmodule-2.0.so.0:
> cannot open shared object file: No such file or directory
> I wasn't sure what to do about this so I thought I'd try the RedHat RPMs
> (RedHat 9.0 x86). Trying to install the core RPM gives me:
>         [root at xxx mono]# rpm -i --test mono-core-
>         error: failed dependencies:
>       	  libc.so.6(GLIBC_2.3)   is needed by mono-core-
>                 libc.so.6(GLIBC_2.3.2)   is needed by
> mono-core-
>                 libglib-2.0.so.0   is needed by mono-core-
>                 libgmodule-2.0.so.0   is needed by
> mono-core-
>                 libgthread-2.0.so.0   is needed by
> mono-core-
>                 libpthread.so.0(GLIBC_2.3.2)   is needed by
> mono-core-
> Therefore, I tried to install glibc but got this:
>         [root at xxx kb]# rpm -i --test glibc-2.3.2-27.9.7vfs3.i386.rpm
>         error: failed dependencies:
>                 glibc-common = 2.3.2-27.9.7vfs3 is needed by
> glibc-2.3.2-27.9.7vfs3
>                 glibc > 2.2.5 conflicts with glibc-common-2.2.5-34
> When trying to install glibc-common I get this:
>         [root at xxx kb]# rpm -i --test glibc-common-2.3.2-27.9.7vfs3.i386.rpm
>         error: failed dependencies:
>                 glibc < 2.3.2 conflicts with glibc-common-2.3.2-27.9.7vfs3
> I'm not sure how to resolve this failed dependency. Has mono been proven to
> install OK on my distro? I'd appreciate any advice here.
> Thanks a lot,
> Kent
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

More information about the Mono-list mailing list