[Mono-list] Problems installing Mono from sources on MDK10.1

Alessandro Bottoni alessandro-bottoni at libero.it
Mon Jun 13 10:13:12 EDT 2005

I just tried to make mono 1.1.7 from sources and install it on my mandrake 

It looks like compilation is going fine (even if I get some warning) but at 
the installation stage I get the following error:

Compilation succeeded - 3 warning(s)
mv mcs.exe ../class/lib/basic/mcs.exe
mv: impossibile to move `mcs.exe' to `../class/lib/basic/mcs.exe': No such 
file or directory
make[6]: *** [../class/lib/basic/mcs.exe] Error 1
make[6]: Leaving directory 
make[5]: *** [install] Error 2
make[5]: Leaving directory 
make[4]: *** [install-recursive] Error 1
make[4]: Leaving directory `/home/alex/temporary/mono-1.1.7/mono-1.1.7/mcs'
make[3]: *** [profile-do--basic--install] Error 2
make[3]: Leaving directory `/home/alex/temporary/mono-1.1.7/mono-1.1.7/mcs'
make[2]: *** [profiles-do--install] Error 2
make[2]: Leaving directory `/home/alex/temporary/mono-1.1.7/mono-1.1.7/mcs'
make[1]: *** [install-exec] Error 2
make[1]: Leaving directory 
make: *** [install-recursive] Error 1
[root at localhost mono-1.1.7]#

I ran the following command:

[alex at localhost mono-1.1.7]$ ./configure --prefix=/usr/local
[alex at localhost mono-1.1.7]$ su
[root at localhost mono-1.1.7]$ make install
Any suggestion?
Alessandro Bottoni

More information about the Mono-list mailing list