[Mono-list] Problem compiling libgdiplus (FC4, Mono 1.1.8)

Peter De Jager peterdj at telkomsa.net
Thu Jul 21 18:38:53 EDT 2005

I am having trouble installing libgdiplus. I have tried both the go-mono
download and svn but I get the same error:

[root at localhost libgdiplus]# ./autogen.sh --prefix=/usr/local/
cairo will be compiled with the following surface backends:
  Xlib: yes
  Quartz: no
  XCB: no (requires XCB http://freedesktop.org/software/xcb)
  PostScript: yes
  PDF: no
  PNG: no (requires libpng http://www.libpng.org)
  glitz: no (requires glitz http://freedesktop.org/software/glitz)
and the following font backends:
  freetype: no
  atsui: no
Configuration summary
   * Installation prefix = /usr/local/
   * Codecs supported:
      - TIFF: yes
      - JPEG: yes
      - GIF: yes
      - PNG: yes
      NOTE: if any of the above say 'no' you may install the
            corresponding development packages for them, rerun
            autogen.sh to include them in the build.
Now type `make' to compile

[root at localhost libgdiplus]# make
if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.
-I.. -I. -I../../libpixman/src   -Wall -Wpointer-arith -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations         -Wnested-externs
-fno-strict-aliasing    -g -O2 -MT cairo_font.lo -MD -MP -MF
".deps/cairo_font.Tpo" -c -o cairo_font.lo cairo_font.c; \
then mv -f ".deps/cairo_font.Tpo" ".deps/cairo_font.Plo"; else rm -f
".deps/cairo_font.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../../libpixman/src -Wall
-Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes
-Wmissing-declarations -Wnested-externs -fno-strict-aliasing -g -O2 -MT
cairo_font.lo -MD -MP -MF .deps/cairo_font.Tpo -c cairo_font.c  -fPIC -DPIC
-o .libs/cairo_font.o
cairo_font.c: In function '_font_cache_create_entry':
cairo_font.c:89: error: 'CAIRO_FONT_BACKEND_DEFAULT' undeclared (first use
in this function)
cairo_font.c:89: error: (Each undeclared identifier is reported only once
cairo_font.c:89: error: for each function it appears in.)
make[4]: *** [cairo_font.lo] Error 1
make[4]: Leaving directory `/root/mono/libgdiplus/cairo/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/root/mono/libgdiplus/cairo'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/root/mono/libgdiplus/cairo'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/mono/libgdiplus'
make: *** [all] Error 2
[root at localhost libgdiplus]#

What do I need to do to fix this? Or what should I search for to find an


More information about the Mono-list mailing list