[Mono-list] RE: Mono Installation Question

Kent Boogaart kentcb at internode.on.net
Fri Jul 1 00:05:18 EDT 2005

Thanks for the suggestions guys. Unfortunately, I'm not any closer to
getting this resolved. If I try updating the RPMs rather than installing I
	# rpm -Uvh glibc-common-2.3.2-27.9.7vfs3.i386.rpm
	error: failed dependencies
		glibc < 2.3.2 conflicts with glibc-common-2.3.2-27.9.7vfs3
		glibc-common = 2.2.4-26 is needed by glibc-2.2.4-26

If I understand this correctly, it won't let me update glibc-common because
it wouldn't be compatible with my existing glibc (which I intend to update
after updating glibc-common). Is that right? Is there maybe a way to tell it
to upgrade glibc at the same time? I tried forcing it (-f) but that resulted
in the same errors.

I had no luck building mono either. It ended up with very similar dependency

Does anyone actually have mono running on Redhat? I have tried both advanced
server and plain old 7.3. Both resulted in the same errors. Mandrake 10
worked just fine.


-----Original Message-----
From: Kent Boogaart [mailto:kentcb at internode.on.net] 
Sent: Wednesday, 29 June 2005 5:02 PM
To: 'mono-list at lists.ximian.com'
Subject: Mono Installation Question

Hi there,

I need some help installing Mono on a Redhat Advanced Server release 2.1AS
system. I'm pretty much a linux noob so please "speak slowly" for me :)

The first thing I tried was the installer for x86. The installation went
smoothly. However, when I tried to run mono I got:
        mono: error while loading shared libraries: libgmodule-2.0.so.0:
cannot open shared object file: No such file or directory

I wasn't sure what to do about this so I thought I'd try the RedHat RPMs
(RedHat 9.0 x86). Trying to install the core RPM gives me:
        [root at xxx mono]# rpm -i --test mono-core-
        error: failed dependencies:
      	  libc.so.6(GLIBC_2.3)   is needed by mono-core-
                libc.so.6(GLIBC_2.3.2)   is needed by
                libglib-2.0.so.0   is needed by mono-core-
                libgmodule-2.0.so.0   is needed by
                libgthread-2.0.so.0   is needed by
                libpthread.so.0(GLIBC_2.3.2)   is needed by

Therefore, I tried to install glibc but got this:
        [root at xxx kb]# rpm -i --test glibc-2.3.2-27.9.7vfs3.i386.rpm
        error: failed dependencies:
                glibc-common = 2.3.2-27.9.7vfs3 is needed by
                glibc > 2.2.5 conflicts with glibc-common-2.2.5-34

When trying to install glibc-common I get this:
        [root at xxx kb]# rpm -i --test glibc-common-2.3.2-27.9.7vfs3.i386.rpm
        error: failed dependencies:
                glibc < 2.3.2 conflicts with glibc-common-2.3.2-27.9.7vfs3

I'm not sure how to resolve this failed dependency. Has mono been proven to
install OK on my distro? I'd appreciate any advice here.

Thanks a lot,

More information about the Mono-list mailing list