[Mono-list] Please Help - Building gtk-sharp from svn on Suse 9.2

Joe Audette joe_audette@yahoo.com
Mon, 31 Jan 2005 17:07:42 -0800 (PST)

Hi Paul,

> > 
> > I was able to compile libgdiplus and mono but
> getting
> > an error trying to compile gtk-sharp. I ran
> autogen
> > with no errors but when I run make I get the error
> > below. Any suggestions appreciated.

> Where does the compile file? Is it where you
> describe below or some
> other place?

Not sure what you are asking me here. I am using

> > I see that the
> > file libesd.la does not exist on my machine.
> Wondering
> > if I can get a copy from somewhere or someone.
> > 
> > grep: /usr/lib/libesd.la: No such file or
> directory
> > /usr/bin/sed: can't read /usr/lib/libesd.la: No
> such
> > file or directory
> libesd is part of ALSA (enlightenment sound daemon),
> no idea why that
> should be trying to be linked to! alsa-devel would
> be somewhere to look.

I'm not sure whats referencing it but I went ahead and
installed alsa-devel just now, did make clean then
./autogen.sh --prefix=/usr
then make and this is what I get:
grep: /usr/lib/libesd.la: No such file or directory
/usr/bin/sed: can't read /usr/lib/libesd.la: No such
file or directory
libtool: link: `/usr/lib/libesd.la' is not a valid
libtool archive
make[3]: *** [libgnomesharpglue-2.la] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/mono/gtk-sharp'
make: *** [all] Error 2

there are some libesd.so.number files (they were there
before even installing alsa-devel in the /usr/lib
directory but still no .la

> When you ran ./autogen.sh at the end of the script
> (on screen) it will
> have told you what was going to be compiled in -
> what did it say?

Configuration summary

   * Installation prefix = /usr
   * C# compiler: /usr/bin/mcs

   Optional assemblies included in the build:

      * art-sharp.dll: yes
      * gnomevfs-sharp.dll: yes
      * gnome-sharp.dll: yes
      * glade-sharp.dll: yes
      * gda-sharp.dll: yes
      * gnomedb-sharp.dll: yes
      * rsvg-sharp.dll: yes
      * gtkhtml-sharp.dll: yes
      * vte-sharp.dll: yes
      * gtk-dotnet.dll: yes

      NOTE: if any of the above say 'no' you may
install the
            corresponding development packages for
them, rerun
            autogen.sh to include them in the build.

Now type `make' to compile

I appreciate your help very much Paul and await any
further suggestions. 

Many Thanks,



Do you Yahoo!? 
Yahoo! Mail - Find what you need with new enhanced search.