[Mono-list] NAnt

Fredrik Elestedt fredrik at elestedt.com
Wed Dec 21 08:36:34 EST 2005

Gert Driesen wrote:
>>-----Original Message-----
>>From: mono-list-bounces at lists.ximian.com 
>>[mailto:mono-list-bounces at lists.ximian.com] On Behalf Of 
>>Fredrik Elestedt
>>Sent: woensdag 14 december 2005 22:56
>>To: mono-list at lists.ximian.com
>>Subject: [Mono-list] NAnt
>>When I tried to recompile mysql-connector-net-1.0.4 I got an 
>>error when
>>it tried to execute NAnt to generate a signed key (using Gentoo). So I
>>decided to recompile NAnt and try again - but that didn't 
>>help so here I
>>Anyone know what could cause this? I'm running mono version 1.0.10.
>># mono /usr/share/NAnt/bin/NAnt.exe
>>** (/usr/share/NAnt/bin/NAnt.exe:31880): WARNING **: Missing method
>>.ctor in assembly /usr/share/NAnt/bin/NAnt.exe, type
>>** ERROR **: Can't find custom attr constructor image:
>>/usr/share/NAnt/bin/NAnt.exe mtoken: 0x0a000056
> I cannot reproduce this issue using Mono svn (also on Gentoo).
> What version of NAnt are you using ?
> Can you try removing all elements from the <startup> node in the NAnt
> application configuration file (NAnt.exe.config) and see if that has any
> effect ?
> Gert

I'm using dev-dotnet/nant-0.85_rc3

I'm not using the SVN of mono - but version dev-lang/mono-

Removing everything in <startup> revealed:
The NAnt configuration file (/usr/share/NAnt/bin/NAnt.exe.config) does
not have a <framework> node for the current runtime framework.

Please add a <framework> node with family 'mono' and clrversion
'2.0.50727' under the 'win32' platform node.

Also tried removing the file and reemerging nant - no luck, same error
as the first time.

// Fredrik

More information about the Mono-list mailing list