[Mono-list] Cannot find Assembly ASP

Gilles FAVIER gilles.favier2605@wanadoo.fr
Thu, 7 Apr 2005 15:12:13 +0200 (CEST)


I am trying to connect to an Oracle database, when i am running my script as an exe file, it compiles and then when i execute it works but when i try to it through a web page, i cannot compile the pages, i get the following error message when i run : 

mcs /t:library /out:WebTest.dll -r:System -r:System.Data -r:System.Collections -r:System.ComponentModel -r:System.Drawing -r:System.Web -r:System.Web.SessionState -r:System.Web.UI -r:System.Web.UI.WebControls -r:System.Web.UI.HtmlControls -r:System.Data.OracleClient  AssemblyInfo.cs Default.aspx.cs Global.asax.cs
error CS0006: Cannot find assembly `System.Collections'
error CS0006: Cannot find assembly `System.ComponentModel'
error CS0006: Cannot find assembly `System.Web.SessionState'
error CS0006: Cannot find assembly `System.Web.UI'
error CS0006: Cannot find assembly `System.Web.UI.WebControls'
error CS0006: Cannot find assembly `System.Web.UI.HtmlControls'
Compilation failed: 6 error(s), 0 warnings

Here is the code of my Default.aspx.cs

----- code start ------
using System;
using System.Collections;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Web;
using System.Web.SessionState;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.HtmlControls;
using System.Data.OracleClient;

namespace WebTest
	/// <summary>
	/// Summary description for _Default.
	/// </summary>
	public class _Default : System.Web.UI.Page
		protected System.Web.UI.WebControls.Button BTGO;
		protected System.Web.UI.WebControls.Label LBResult;
		protected System.Web.UI.WebControls.Label LBSQL;
		private void Page_Load(object sender, System.EventArgs e)
			// Put user code to initialize the page here

		#region Web Form Designer generated code
		override protected void OnInit(EventArgs e)
			// CODEGEN: This call is required by the ASP.NET Web Form Designer.
		/// <summary>
		/// Required method for Designer support - do not modify
		/// the contents of this method with the code editor.
		/// </summary>
		private void InitializeComponent()
			this.BTGO.Click += new System.EventHandler(this.BTGO_Click);
			this.Load += new System.EventHandler(this.Page_Load);


		private void BTGO_Click(object sender, System.EventArgs e)
			LBResult.Text = "";

			string connectionString = 
				"Data Source=XXXXX;User ID=XXXXXX;Password=XXXXXX;";
			OracleConnection dbcon = null;
			dbcon = new OracleConnection (connectionString);
			dbcon.Open ();
			OracleCommand dbcmd = dbcon.CreateCommand ();
			string sql = LBSQL.Text;
			dbcmd.CommandText = sql;			
			OracleDataReader reader = dbcmd.ExecuteReader ();
				LBResult.Text += (string) reader["COUNTER"].ToString() + "<BR>";

			reader.Close ();
			reader = null;
			dbcmd.Dispose ();
			dbcmd = null;
			dbcon.Close ();
			dbcon = null;

----- code end -------

I am pretty sure the problem comes from the fact that it cannot find the DLLs but i have no idea how to find them and to link them. And to be honest whe i run a search in Linux i don't find them really, only the directory with the same name.
I am running RED HAT ES 3.0 with the oracle client 9204 on a VMWARE virtual Machine and i am using mono 1.0.6 (the downloadable packages from the official web site)

If Someone has an idea where is my problem...
Have a good day!