[Mono-list] mod_mono does not start XSP

Golo Haas haas@folz.de
Fri, 24 Sep 2004 11:00:05 +0200

Hi there,

> Can You send some more info...

yes, of course.

> Have you installed it from rpm or from source?

I have installed Mono 1.0.1 using Red Carpet's Mono channel. Since mod_mono has not been included in 1.0.1, I have downloaded the appropriate RPM from http://www.go-mono.com/archive/1.0.2/suse-91-i586/mod_mono-1.0.1-0.ximian.9.0.i586.rpm and installed it using

rpm -ivh mod_mono-1.0.1-0.ximian.9.0.i586.rpm

on my machine. Apache 2.0.49 is the version that has been included within my SuSE 9.1 box with any additional updates that might have been done by SuSE's online update automatically.

The httpd.conf file is the default httpd.conf by SuSE, I only changed the line

DirectoryIndex index.html index.html.var


DirectoryIndex Default.aspx index.html index.html.var

in order to get Default.aspx as start page of an ASP.NET website. Additionally, the file default-server.conf is included into httpd.conf by SuSE, so I modified that file, too, and added the following lines:

LoadModule mono_module /usr/lib/apache2/libmod_mono.so
Alias /test "/home/gh/XSP"
MonoApplications "/test:/home/gh/XSP"
<Location /test>
        Order allow,deny
        Allow from all
        AddHandler mono .aspx .ascx .asax .ashx .cs .config .asmx

Loading of the module is working, since Apache gives me an error if I comment that line out that the command MonoApplications is unknown. Next, I define a mono application and give access to anyone. I have tried to replace the AddHandler command by the following line

SetHandler mono

but that did not change anything. In my /var/log/apache2/error_log, the only message that is shown is

[Fri Sep 24 10:56:06 2004] [error] Failed connecting. No such file or directory

that's all. I spend a little time experiencing with the ps command and found out that after a reboot there are some httpd threads, no mono. If it try to access http://mymachine/test for the first time, two mono processes are loaded and stay in memory. Every time I try to get access to the location again, a new mono process is started. Anyway, nothing happens on the web except the server error 503, that the service is temporarily unavailable.

I have tried to change Apache's log level to "debug", but that only gave me a bunch of additional, but unrelated messages :-(. An additional error log file for XSP does not seem to exist.

If I start mod-mono-server manually, everything works fine, but that's not a real conclusion, since mod_mono should (according to the docs) be able to start it automatically. That's, what the setting "MonoRunXSP True" is for, but either if I include it in httpd.conf or if I leave it out, it does not change anything.

So, that's my results of the moment, has anyone got an idea?

Thanks so much in advance for your help!

Golo Haas				f o l z . communication & networks GmbH
haas@folz.de				Kaiserslautern, Germany
Tel.: +49 631 371480			http://www.folz.de/