[Mono-list] Mono compilation problems (Solaris 8, SPARC)

Harry Sufehmi milis-2@harrysufehmi.com
Thu, 02 Sep 2004 11:52:45 +0100

Hi Gonzalo,

Thanks for your reply below - however, I just tried both Sep 01 snapshot 
and the XSP source from CVS, and both gives me the same error message.

Could you please help us again with this ? We have a vendor coming 
tomorrow to install an eLearning software, and they need Mono to run 
their software.

Many thanks,

Gonzalo Paniagua Javier wrote:
> On Wed, 2004-09-01 at 08:10, Harry Sufehmi wrote:
>>Thanks to Jeremy and Mono team for releasing Mono v1.0.1, I've been able 
>>to compile Mono and XSP webserver successfully on a Sun server running 
>>Solaris 8.
>>However, when I tried to run the XSP webserver, I got the following 
>>error message:
>>bash-2.99# /bcc/mono-1.0.1/bin/mono /usr/local/xsp-1.0.1/bin/xsp.exe 
>>--port 40000
>>Adding applications '/:.'...
>>Registering application:
>>     Host:          any
>>     Port:          any
>>     Virtual path:  /
>>     Physical path: /usr/local/xsp-1.0.1/share/doc/xsp/test
>>Listening on port: 40000
>>Listening on address:
>>Root directory: /usr/local/xsp-1.0.1/share/doc/xsp/test
>>Unhandled Exception: System.Net.Sockets.SocketException: Invalid arguments
>>in <0x009e8> System.Net.Sockets.Socket:Select 
>>in <0x00118> Mono.ASPNET.ApplicationServer:RunServer ()
>>in <0x0008c> (wrapper delegate-invoke) 
>>System.MulticastDelegate:invoke_void ()
>>Hit Return to stop the server.
>>I'm clueless at the moment as what to do now to resolve this problem.
>>If you have any idea about it, do please let me know.
> Yes. Solaris does not support setting the timeout on a socket. Try CVS
> version of xsp, as that exception is ignored now in case it happens.
> -Gonzalo