[Mono-list] Mono compilation problems (Solaris 8, SPARC) - also on Red Hat 9

Barbara Plank, Idealnet barbara@idealnet.com
Thu, 2 Sep 2004 08:36:38 +0200

Hi Gonzalo,

I have exactly the same problem with Apache and Mono 1.0.1 but on Red hat 9.
Is it perhaps for the same reason? (does Red Hat also not allow a timeout on
a socket?). 
By the way, I installed Mono through red carpet, and version 1.0 worked
fine, just with 1.0.1 I have this problem.

And thanks for any hint,

And... I posted my problem already on
92306582 but I got no replies... - by the way: does there anywhere exist
another mono-forum or newsgroup? Just as info, thanks

-----Original Message-----
From: mono-list-admin@lists.ximian.com
[mailto:mono-list-admin@lists.ximian.com] On Behalf Of Gonzalo Paniagua
Sent: Mittwoch, 01. September 2004 17:59
To: mono-list@lists.ximian.com
Subject: Re: [Mono-list] Mono compilation problems (Solaris 8, SPARC)

On Wed, 2004-09-01 at 08:10, Harry Sufehmi wrote:
> Thanks to Jeremy and Mono team for releasing Mono v1.0.1, I've been able 
> to compile Mono and XSP webserver successfully on a Sun server running 
> Solaris 8.
> However, when I tried to run the XSP webserver, I got the following 
> error message:
> ==============================
> bash-2.99# /bcc/mono-1.0.1/bin/mono /usr/local/xsp-1.0.1/bin/xsp.exe 
> --port 40000
> xsp
> Adding applications '/:.'...
> Registering application:
>      Host:          any
>      Port:          any
>      Virtual path:  /
>      Physical path: /usr/local/xsp-1.0.1/share/doc/xsp/test
> Listening on port: 40000
> Listening on address:
> Root directory: /usr/local/xsp-1.0.1/share/doc/xsp/test
> Unhandled Exception: System.Net.Sockets.SocketException: Invalid arguments
> in <0x009e8> System.Net.Sockets.Socket:Select 
> in <0x00118> Mono.ASPNET.ApplicationServer:RunServer ()
> in <0x0008c> (wrapper delegate-invoke) 
> System.MulticastDelegate:invoke_void ()
> Hit Return to stop the server.
> ==============================
> I'm clueless at the moment as what to do now to resolve this problem.
> If you have any idea about it, do please let me know.

Yes. Solaris does not support setting the timeout on a socket. Try CVS
version of xsp, as that exception is ignored now in case it happens.


Mono-list maillist  -  Mono-list@lists.ximian.com