[Mono-list] mod_mono: connect error

Gonzalo Paniagua Javier gonzalo.reply.to.the.list.iam.subscribed@ximian.com
Wed, 01 Sep 2004 11:34:36 -0400

On Tue, 2004-08-31 at 12:29, dmclaughlin@mindspring.com wrote:
> I am having problems with mod-mono-server on Slackware 10 running Apache 1.3.31. I installed and compiled mono, xsp and mod_mono without error. The only thing I did out of the ordinary is to set the prefix for all three installations to /usr/local instead of /usr.
> Other than the installation prefix issue, I have followed the instructions in INSTALL to the letter. I have these lines in my httpd.conf file:
> LoadModule mono_module        libexec/libmod_mono.so
> AddModule mod_mono.c
> Alias /demo "/usr/local/share/doc/xsp/test"
> MonoApplications "/demo:/usr/local/share/doc/xsp/test"
> <Directory /usr/local/share/doc/xsp/test>
> 	SetHandler mono
> 	<IfModule mod_dir.c>
> 		DirectoryIndex index.aspx
> 	</IfModule>
> </Directory>
> (libmod_mono.so is definitely in /usr/local/apache/libexec/libmod_mono.so)
> When I run the demo pages with xsp, they work fine. However, when I run them in Apache, I get the following in the error_log:
> 	[error] (13)Permission denied: mod_mono: connect error (Permission denied). File: /tmp/mod_mono_server

That's pretty clear. The user running apache doesn't have permission to
connect to that file. Check out the permissions. Or, even better, remove
the file as it's probably the result of running mod-mono-server.exe as
other user.