[Mono-list] mono-1.1.1 + xsp / mod_mono

Mike Morano mmorano@mikeandwan.us
Fri, 29 Oct 2004 14:22:42 -0400


I've discovered that the error is not with machine.config, which makes sense, 
otherwise many people would have noticed this before.  The problem appears to 
be with reading information from web.config.  

If I completely remove the web.config file, the web application properly 
served pages. Next, I tried pulling out small sections of the web.config to 
see if there was something particular causing the error, but regardless of 
what was in the web.config file, the application would always give me the 
error below.

Has anyone else had problems when using a web.config?

It looks like there might be 2 bugs to report, the first is in regards to the 
error messaging pointing to machine.config, and secondly, improperly handling 
a web.config.


On Friday 29 October 2004 09:19 am, Mike Morano wrote:
> Hello,
> I am having difficulty in getting xsp (1.0.2) or mod_mono (1.0.1) to work
> with mono 1.1.1 (so I can use the jit).  I just upgraded from an x86
> machine to an amd64 machine, and simply copied my (working) configurations
> across to the new box.
> However, the first time I try to access my site either through XSP or
> mod_mono, I get the following error message in the browser:
> Server error in '/' application
> Description: Error processing request.
> Error Message: HTTP 500.
> Stack Trace:
> System.Runtime.Remoting.RemotingException: Configuration file
> '/usr/etc/mono/1.0/machine.config' could not be loaded: Expected element
> in [0x00012] (at /cvs/mcs/class/System.Web/System.Web/HttpRuntime.cs:120)
> System.Web.HttpRuntime:OnFirstRequestStart (System.Web.HttpContext)
> in [0x0004c] (at /cvs/mcs/class/System.Web/System.Web/HttpRuntime.cs:282)
> System.Web.HttpRuntime:InternalExecuteRequest
> (System.Web.HttpWorkerRequest)
> I have not touched the machine.config in any way.  In case it helps, you
> can find machine.config attached.
> Has anyone else run into this?  I did try the stable 1.0.2 version of mono
> (w/o the jit), and when I tried to access a page, mint took 100% cpu for a
> couple minutes and never returned a page.
> TIA,
> Mike