[Mono-list] compiling mono on ubuntu

Matt Nuzum matt@followers.net
Mon, 29 Nov 2004 09:48:41 -0500

On Sun, 28 Nov 2004 19:26:11 -0800 (PST), Eduardo Osorio Armenta
<e_osorio@yahoo.com> wrote:
> i have a running mono runtime (1.0.1)
> under ubuntu warty.
> but recently downloaded the svn of mono mcs gtk-sharp
> to compile mono 1.1.2
> follow instructions for building mono
> ./autogen.sh --prefix=/home/eduardo --with-preview=yes
> but
> ....

I went through this excercise last night, except I wanted the 1.0.4
release.  I had to use synaptic to install a lot of additional *-dev
packages before things would work correctly.  I basically worked
entirely off of the mono download page and out of the normal (main?)
branch in Ubuntu and worked through the dependencies one by one.  I
didn't have to go to Universe to meet any of the requirements, but I
did have to go to the 1.0 section of mono to get Gecko# and

In the end, I have mono installed at --prefix=/usr but unfortunately,
something funny is still happening with my Gtk# installation because
none of my Gtk# programs compile or run.  There's an error, but I'm
not at my computer now and I can't remember what it was. Seems like it
was having troubles locating the stuff for gtk#.

If anyone knows of some tips to get things working, I'd like to hear.
Also, if people are interested I'll see if I can find out what I had
to do to get everything to compile and install.

Matthew Nuzum <matt@followers.net>
www.followers.net - Makers of "Elite Content Management System"
View samples of Elite CMS in action by visiting