[Mono-list] mod_mono not working: "Abnormal string size."

Michael Elsdörfer michael@elsdoerfer.net
Fri, 26 Nov 2004 16:42:13 +0100

Hi everybody,

I hope somebody can help me getting mod_mono running on my debian server
(Apache 2).

I tried it a few months ago, I think with version 1.0, but mod-mono-server
always threw this exception when a request came in:

System.ArgumentOutOfRangeException: Abnormal string size.
Parameter name: size
in <0x00065> Mono.ASPNET.ModMonoRequest:ReadString ()
in <0x00050> (wrapper remoting-invoke-with-check)
Mono.ASPNET.ModMonoRequest:ReadString ()
in <0x000a9> Mono.ASPNET.ModMonoRequest:GetInitialData ()
in <0x0004f> (wrapper remoting-invoke-with-check)
Mono.ASPNET.ModMonoRequest:GetInitialData ()
in <0x000ef> Mono.ASPNET.ModMonoRequest:.ctor
(System.Net.Sockets.NetworkStream)in <0x00056> (wrapper remoting-invoke-
with-check) Mono.ASPNET.ModMonoRequest:.ctor
in <0x00034> Mono.ASPNET.RequestReader:.ctor
in <0x00077> Mono.ASPNET.ModMonoWorker:Run (object)

Now I gave it again a shot, using the latest sources from subversion for
mono (+mcs), xsp, and mod_mono, and I still get the same message, though
without a stack trace this time:

In ModMonoWorker.Run: Abnormal string size.
Parameter name: size

Anybody who can help?