[Mono-list] Problem with GTK-Sharp compilation on FC3

Matt Nuzum matt@followers.net
Mon, 22 Nov 2004 09:19:38 -0500

On Mon, 22 Nov 2004 00:53:09 +0100, Gilles Fabio
<gilles.fabio@laposte.net> wrote:
> Hi everyone !
> I'm rebuilding Fedora Core 2 Mono's RPMs for Fedora Core 3. I have a
> problem with gtk-sharp during installation process (%install) :

> Somebody could help me ?
> Regards,
> Gilles
I found these: http://xplib.de/mono.php last night (I was trying the
same thing as you I guess). Just a warning, you can't use wget to
download the whole lot, you must click on each in turn.  Make sure
that it doesn't try to open with a texteditor.  For somereason if I
tried to download more than two at once the third would open in a text
editor and gedit would just give an error.

The only one that gave me trouble was monodoc. There's something wrong
with his RPM.  I installed the packages that didn't depend on it, then
rebuilt the rpm with rpmbuild --rebuild monodoc*.src.rpm and then
installed it as well as the remaining rpms.

I did some quick testing last and found simple Gtk apps worked fine.

Hope this helps,

Matthew Nuzum		| Makers of "Elite Content Management System"
www.followers.net		| View samples of Elite CMS in action
matt@followers.net		| http://www.followers.net/portfolio/