[Mono-list] Mod_mono permission issues...

Arnaud Bienvenu arnaud.bienvenu@makina-corpus.org
Wed, 17 Nov 2004 18:30:05 +0100

Charles Martin a écrit :
> System.UnauthorizedAccessException: Access to the path "/root/tmp/nobody-temp-aspnet/e367c7b0" is denied.
> I tried to put the permissions to 777 on that folder 
> (/root/tmp/nobody-temp-aspnet) recursively but with no luck, I also 
> tried to chown it to apache:apache and nobody:nogroup (also recursively) 
> without any luck either...

If you juste typed : chmod -R 777 /root/tmp/nobody-temp-aspnet
this is not enough, since on Mandrake /root/tmp is only executable by 
root. You should also type :
chmod a+rx /root/tmp

However, this is a dirty hack, mod_mono should definitely write to /tmp, 
not /root/tmp. I guess your apache2 installation is broken. If you 
install apache2 through urpmi (which is much easier), it will write to 
/tmp/apache-temp-aspnet, and you will not have any problem.

So I suggest you remove your source-compiled apache, install packaged 
apache2 and apache2-dev, recompile and reinstall mod_mono, and 
everything should be fine. I tested it for you with mono/mod_mono 1.0.4 
on Mandrake 10.0, and the xsp demos work like a charm.

Arnaud Bienvenu
Makina Corpus