[Mono-list] DirectoryServices class

Nigel Benns nigel_benns@rogers.com
Mon, 1 Nov 2004 06:35:01 -0500 (EST)

Damn I feel dumb....

I changed the ugly [arg[2]][0] to [arg[2]].Value and it worked for my code...

Reading Monodoc and finding out what class I was dealing with at the time
helped... :(

But at least it works now...

I still don't understand why your code throughs an exception though?
BTW, it throws it on my computer right where it creates the DirectoryEntry
(the first .Add).

I encapsulated it in a try/catch and found it threw the exception... I
wonder why the hell that is?  It works?

> Nigel Benns a écrit :
>> I've had quite a bit of success working with some test programs and
>> OpenLdap, but the only thing I cannot do is write to the directory
>> store.
>> DirectoryEntry.CommitChanges() runs and exits ok, but doesn't seem to
>> really do anything. Then next time I run it, or read the directory in GQ
>> the entry is still exactly the same.
> CommitChanges() works fine for me from mono-1.0.0 to mono-1.1.1, and I
> can write to OpenLDAP (2.0 and 2.1). Are you sure there is no exception
> ? Maybe your binding is wrong, or you do not respect the LDAP schema...
> Attached is an example code of mine that creates a user entry. You could
> also send me your code so I can test it.
>> Right now I'm using Mono-1.0 with Linux Mandrake 10.1 (actually Cooker,
>> I'm going to redo my Laptop with 10.1 PowerPack now that its out)
> I use Mandrake 10.0 and Debian Sarge.
> --
> Arnaud Bienvenu
> Makina Corpus