[Mono-list] 0.9x can't compile on mac os x

Attila Balogh d0lphin@mail.edu-net.hu
Mon, 31 May 2004 19:26:08 +0200

hello all,

i'm still getting the same error message when trying to compile mono (i 
tried 0.92-3-4 and cvs version when i could grab them - 0.91 builds 
without errors of course), the error occurs at mini:

gcc -g -O2 -fno-strict-aliasing -g -Wall -Wunused -Wmissing-prototypes 
-Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes 
-Wnested-externs -Wpointer-arith -Wno-cast-qual -Wcast-align 
-Wwrite-strings -pthread -o mono main.o  ./.libs/libmono.a -L/sw/lib 
-lgthread-2.0 -lgmodule-2.0 -lglib-2.0 /sw/lib/libintl.a -liconv 
-licui18n.28 -licuuc.28 -licudata.28 -lpthread -lm
gcc: unrecognized option `-pthread'
ld: table of contents for archive: /sw/lib/libintl.a is out of date; 
rerun ranlib(1) (can't load from it)
make[4]: *** [mono] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

any ideas, is this a bug or i'm messing something up?