[Mono-list] ByteFX.Data broken in Beta1?

Artur Brodowski bzdurqa@wp.pl
Tue, 25 May 2004 14:10:42 +0200

W li¶cie z wto, 25-05-2004, godz. 12:35 +0100, Scott Lowe napisał: 
> Make sure that you have the latest and greatest release of the 
> ByteFX.Data data provider

Well, I did try that already - Debian, Mono beta1, latest (0.75)

> I used ByteFX.Data version 0.76 and Mono Beta1 to compile your console
> application on Win XP and it worked fine

But there's no ByteFX.Data.dll in 0.76 .zip file, looks like it was
renamed to ByteFX.MySqlClient in latest version and it probably 
causes some namespaces issues.
I've tried to connect to MySQL from sqlsharp tool, but it also has

SQL# \connectionstring server=localhost;databasedb;User

SQL# \provider mysqlnet
The default Provider is LOADEXTPROVIDER
          Assembly: ByteFX.Data
  Connection Class: ByteFX.Data.MySQLClient.MySQLConnection

SQL# \open
Attempt to open connection...
Loading external provider...
Error: unable to load the assembly of the provider: ByteFX.Data : File
'ByteFX.Data' not found.

$ ls -l /usr/lib/mono/1.0/ByteFX.*
-rw-r--r--  1 root root 122880 maj 25
13:45 /usr/lib/mono/1.0/ByteFX.Data.dll  <-- 0.75
-rw-r--r--  1 root root 159744 maj 25
13:03 /usr/lib/mono/1.0/ByteFX.MySqlClient.Design.dll
-rw-r--r--  1 root root 102400 maj 25
13:03 /usr/lib/mono/1.0/ByteFX.MySqlClient.dll  <-- 0.76

I've tried to use 0.76 version (\loadextprovider ByteFX.MySqlClient ...)
but it complains about not finding ByteFX.MySqlClient.dll file, so no
luck here either. Ppl on #mono confirmed the same strange behaviour on 
Gentoo box.

only so many songs can be sung with two lips two lungs and one tongue