[Mono-list] Monodoc (installing mono)

John BouAntoun jbouantoun@rogen.com.au
Mon, 24 May 2004 16:28:05 +1000


I think you need libgtkhtml-3.0.so or something.

Anyway I'm pretty sure that Evolution supplies the libtgtkhtml-3.0 so
file (library) but in redhat distro's I've noticed you need to do a
symbolic link from the actual libgtkhtml-3.x so file from the
libgtkhml-3.0 that monodoc is expecting.

Also I think that the pc file need to build monodoc is include in the
devel package of libgtkhtml-3



-----Original Message-----
From: mono-list-admin@lists.ximian.com
[mailto:mono-list-admin@lists.ximian.com] On Behalf Of Morten Krog
Sent: Monday, 24 May 2004 5:24 AM
To: mono-list@lists.ximian.com
Subject: [Mono-list] Monodoc (installing mono)

I've tried to get monodoc to run for every new release of mono without

Today I've tried on my brand new FC2 install and the same problem
occurs. A dependency to gtkhtml-3.0 is not met and the app crashes.

I've used the ximian supplied rpms for FC1 (I know, they are probably
not supposed to work for FC2, but they didn't work better for FC1).

Which rpm supplies this famous gtkhtml-3.0.dll and where is it supposed
to reside?

I've not forces installation of any of the mono rpms.

This is the error message I get:

Unhandled Exception: System.DllNotFoundException: gtkhtml-3.0 in
<0x00053> (wrapper managed-to-native) Gtk.HTML:gtk_html_new () in
<0x00021> Gtk.HTML:.ctor () in [0x001aa] (at
s:209) Monodoc.Browser:.ctor () in [0x00120] (at
s:81) Monodoc.Driver:Main (string[])

Is it just me or is the references to /home/duncan... kinda wierd? I
don't have a user named Duncan on my box.

Any help is appreciated.

/Morten Krog

Mono-list maillist  -  Mono-list@lists.ximian.com