[Mono-list] Monodoc (installing mono)

Morten Krog fafner@fafner-net.dk
Sun, 23 May 2004 21:24:27 +0200

I've tried to get monodoc to run for every new release of mono without

Today I've tried on my brand new FC2 install and the same problem
occurs. A dependency to gtkhtml-3.0 is not met and the app crashes.

I've used the ximian supplied rpms for FC1 (I know, they are probably
not supposed to work for FC2, but they didn't work better for FC1).

Which rpm supplies this famous gtkhtml-3.0.dll and where is it supposed
to reside?

I've not forces installation of any of the mono rpms.

This is the error message I get:

Unhandled Exception: System.DllNotFoundException: gtkhtml-3.0
in <0x00053> (wrapper managed-to-native) Gtk.HTML:gtk_html_new ()
in <0x00021> Gtk.HTML:.ctor ()
in [0x001aa] (at
/home/duncan/conf/mono-conf/monodoc/BUILD/monodoc-0.15/browser/browser.cs:209) Monodoc.Browser:.ctor ()
in [0x00120] (at
/home/duncan/conf/mono-conf/monodoc/BUILD/monodoc-0.15/browser/browser.cs:81) Monodoc.Driver:Main (string[])

Is it just me or is the references to /home/duncan... kinda wierd? I
don't have a user named Duncan on my box.

Any help is appreciated.

/Morten Krog