[Mono-list] mod_mono on SuSE 9 apache2

Gonzalo Paniagua Javier gonzalo@ximian.com
Mon, 10 May 2004 22:18:30 +0200

El lun, 10-05-2004 a las 22:00, Adam Jacob escribió:
> I'm having trouble getting mod_mono 0.9 running with the stock SuSE 9
> apache2.  Using all the rpm's from mono beta 1, and mod_mono compiled
> against the apache2-prefork in SuSE 9. Including a config that looks
> like the following from /etc/apache2/conf.d:
> LoadModule mono_module /usr/lib/apache2/libmod_mono.so
> Alias /mono "/usr/share/doc/xsp/test"
> MonoApplications "/mono:/usr/share/doc/xsp/test"
> MonoRunXSP True
> MonoUnixSocket "/tmp/mod_mono_server"
> MonoExecutablePath "/usr/bin/mono"
> MonoServerPath "/usr/bin/mod-mono-server.exe"
> <Directory /usr/share/doc/xsp/test>
> 	SetHandler mono
> 	Order allow,deny
> 	Allow from all
> </Directory>
> When I hit http://localhost/mono/index.aspx, I get the raw source.. no
> spawning of mod-mono-server.exe, no creation of /tmp/mod_mono_server. 
> Also nothing shows up in the error log, besides a regular page request.
> Does anybody have this working with the apache2 prefork mpm on SuSE 9? 
> Am I just being a moron? (Likely!)  

I just tried the same lines that you have (but i run apache2 as a
non-privileged user and on port 8080) and it worked fine. I can only
think of permissions problems...