[Mono-list] mod_mono problems after upgrade to beta1

Gonzalo Paniagua Javier gonzalo@ximian.com
Thu, 06 May 2004 12:04:54 +0200

El jue, 06-05-2004 a las 11:54, Trond Arve Nordheim escribió:
> Gonzalo Paniagua Javier wrote:
> > El mié, 05-05-2004 a las 14:16, Trond Arve Nordheim escribió:
> >>This is what I get in my error-log:
> >>** (/usr/bin/mod-mono-server.exe:4295): WARNING **: cant resolve 
> >>internal call to 
> >>"System.Net.Sockets.Socket::Socket_internal(System.Net.Sockets.AddressFamily,System.Net.Sockets.SocketType,System.Net.Sockets.ProtocolType)" 
> >>(tested without signature also)
> > Mmm, weird problem. That internal call has been there for a long time
> > and hasn't changed. Ensure you don't have any other mono installation
> > around. Otherwise, looks like an installation problem.
> I installed the previous versions from source, and just installed the 
> beta1 version over the old one - that will do, won't it?

I'm no completely sure of this. May be removing everything related to
mono and reinstalling helps.

> The strange thing is that it works when I run the command manually, as I 
> mentioned.. It's just when Apache starts it it's a problem.. And I run 
> exactly the same command as mod_mono does - both as root and www-data..

May be you have a copy in /usr and other in /usr/local and depending on
where you installed mod_mono it uses one or the other.