[Mono-list] CVS compile errors :(

Andrew Arnott AndrewArnott@byu.edu
Sat, 1 May 2004 07:30:37 -0600

I tried that.  It started building, as if rebuilding from scratch using
the daily snapshot would work, then it gives an error partway through
the compile:

gcc -g -02 -fno-strict-aliasing -g -Wall -Wunused -Wmissing-prototypes
-Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes
-Wnested-externs -Wpointer-arith -Wno-cast-qual -Wcast-align
-Wwrite-strings -o .libs/mint main.o ./.libs/libmint.so -L/opt/gnome/lib
/opt/gnome/lib/libgthread-2.0.so /opt/gnome/lib/libgmodule-2.0.so -ldl
/opt/gnome/lib/libglib-2.0.so -lnsl -lpthread -lm -lrt -Wl,--rpath
-Wl,/usr/local/lib -Wl,--rpath -Wl,/opt/gnome/lib

./.libs/libmint.so: undefined reference to `ures_getStringByIndex_2_6'
./.libs/libmint.so: undefined reference to `ures_getDisplayName_2_6'

And a dozen other undefined references all like those two.  I tried
removing traces of the Mono 0.31 install as well to see if old
dependencies got in the way, but it seems to not have any effect.

- Andrew

-----Original Message-----
From: Iain McCoy [mailto:iain@mccoy.id.au]=20
Sent: Friday, April 30, 2004 7:09 PM
To: Andrew Arnott
Subject: RE: [Mono-list] CVS compile errors :(

On Sat, 2004-05-01 at 05:40, Andrew Arnott wrote:
> I tried downloading a MonoLite, then a MonoCharge, and finally the
> mono snapshot of the day.  Now I have the binaries to the latest
> mscorlib.dll and mcs.exe, but mcs.exe won't run because the runtime
> (mono) is out of sync with mscorlib.dll I cannot find the mono
> executable anywhere in the snapshot (it's not with the other .exe's in
> the snapshot).  How can I get a binary of the latest runtime?  How can
> compile it with a broken compiler?
I found that the full snapshot had the basic ./configure; make; make
install process to get you both the runtime and the compiler.
Iain McCoy <iain@mccoy.id.au>