[Mono-list] SQLsharpgtk problem ( mono 0.31 / gtk-sharp 0.17 ) ]

Gonia Eric - egonia egonia@mail15.com
Mon, 29 Mar 2004 13:53:50 -0600

I am running a little older version of mono (cvs around 0.30.2) and
gtk-sharp (cvs around 0.17) and sqlsharpgtk from this morning with no
problems. I am running queries like:

select Polling.PollerID, Objects2.DisplayName as RootObject,
Objects3.DisplayName as Interface, Objects.DisplayName as Statistic from
Polling inner join Objects on Polling.ObjectID=Objects.ObjectID inner
join Objects as Objects2 on Objects.RootObjectID=Objects2.ObjectID inner
join Topology on Objects.ObjectID=Topology.Child inner join Objects as
Objects3 on Objects3.ObjectID=Topology.Parent where PollerID=-998

I will try to do an update of mono and gtk-sharp over the next day or so
and see what I can cause to break.

In the mean time, I hope someone else can be of more help,

On Mon, 2004-03-29 at 13:01, Martin Eckschmiedt wrote:
> Hi list,
> I installed the updated sqlsharpgtk from anon-cvs, and successfully build
> it.
> But when I run some a little more complex queries against MS-SQL Server 7
> the program just hangs in my Suse 9 box.
> If I run the same query from win32/isql I got the results without a problem.
> The query is as simple as "select * from products where name like
> 'tennis%'".
> The expected result-set is about 100 rows long.
> Other simpler queries work just fine.
> Any help will be great.
> Martin