[Mono-list] Error with .config files

Carlos Alberto Cortez carlos@unixmexico.org
Thu, 17 Jun 2004 23:26:56 -0500


I asked this at IRC but it looks like nobody has had this problem: I
recenlty updated from cvs (both mono & mcs and gtk-sharp), but when I
try to run any Gtk-sharp app it complies:

Unhandled Exception: System.DllNotFoundException: libgtk-win32-2.0-0.dll

I tried copying the dll to so mappings from the
mono/gac/gtk-sharp/version/gtk-sharp.dll.config to the main mono config
file ($prefix/etc/mono/config) and it worked. But when I try to run an
app with glade it complies again with a similar message (this time
telling that libglade is not present). Then I copied the mappings from
glade-sharp.dll.config to the main config file.

However, I'm needing more and more copies of the config files. So I'm
thinking that maybe the installed runtime is having problems or ignoring
the .config files that come with the assemblies that need the mappings.

I've updated from cvs again, but the problem remains.