[Mono-list] Wanted: libgobject-2.0-0.dll

Iain McCoy iain@mccoy.id.au
Fri, 11 Jun 2004 21:34:23 +1000

I think you can't find it because it doesn't exist. Here's what should
be happening:

1. gtk-sharp loads a library, addressing it by it's win32 library name
2. mono's runtime mappings mechanism goes "aha! I know that dll, you
really want this .so file"
3. mono loads the .so file, instead of the dll

What appears to be happening is that the mappings stuff isn't kicking
in. One way this could happen is if you still have pre-gac gtk-sharp
assemblies installed on your system somewhere, because the mappings
mechanism changed when the gac was introduced but old gtk-sharp
assemblies depend on that change not having happened. You're sure you
don't have any such assemblies sitting around? A popular way of
acquiring them was to fail to uninstall 0.31 before installing beta1.

If you haven't got any old gtk-sharp libraries installed, it's not
something I know of an easy fix for (but maybe someone else does). What
I would suggest is that you generally poke around. You'll find the
gtk-sharp mappings in
$prefix/lib/mono/gac/gtk-sharp/; is there a gobject mapping there? Can you reasonably expect the runtime to find the .so file? Is the .so file present?

Good luck.

On Fri, 2004-06-11 at 20:35, Fabricio Santos wrote:
> I believe my problem is slightly different as I'm trying to run monodevelop
> and not my own developed application.
> Besides I can't find the library anywhere... :-(
> -fs
> -----Original Message-----
> From: mono-list-admin@lists.ximian.com
> [mailto:mono-list-admin@lists.ximian.com] On Behalf Of Peter Boos
> Sent: Friday, June 11, 2004 10:47
> To: mono-list@lists.ximian.com
> Subject: [Mono-list] Wanted: libgobject-2.0-0.dll
> Hi,
> I ran into similar problems after installing the beta2 version of gtk-sharp.
> I 
> found out that the sample application in the gtk-sharp tarball working fine,
> but my application starts with missing dlls exception.
> I referenced (via mcs -r:... ) the gtk-sharp.dll directly from the tarball
> and 
> my app worked fine then. That's enough for me, but generally I think make 
> install is broken in some way.
> Regards,
> 	Peter
> _______________________________________________
> Mono-list maillist  -  Mono-list@lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list
> _______________________________________________
> Mono-list maillist  -  Mono-list@lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list
Iain McCoy <iain@mccoy.id.au>