[Mono-list] Problems using gtk-sharp from cvs

Francisco Figueiredo Jr. fxjrlists@yahoo.com.br
Tue, 01 Jun 2004 14:48:53 -0300

Jonathan Pryor wrote:
> Below...
> On Tue, 2004-06-01 at 00:55, John BouAntoun wrote:
> <snip/> 
>>The following is what i get when I run the treeviewdemo in the
>>gtk-sharp/demos folder.
>>[john@nkotb sample]$ mono treeviewdemo.exe
>>Unhandled Exception: System.DllNotFoundException: glibsharpglue
>>in <0x00053> (wrapper managed-to-native) GLib.Object:gtksharp_object_newv (intptr,int,string[],GLib.Value[])
>>in <0x00060> GLib.Object:CreateNativeObject (string[],GLib.Value[])
>>in <0x00131> Gtk.TreeStore:.ctor (System.Type[])
>>in <0x00088> GtkSamples.TreeViewDemo:PopulateStore ()
>>in <0x0002c> GtkSamples.TreeViewDemo:.ctor ()
>>in <0x0001b> GtkSamples.TreeViewDemo:Main (string[])
>>Everthing executed make and sudo make install with no apparent erros,
>>but I can't seem to run a gtk-sharp app at all.
>>The file it claims that it can't see is located here:
>>[john@nkotb john]$ locate glibsharpglue
> Is /usr/local/lib in your LD_LIBRARY_PATH environment variable? :-)
> You might want to add /usr/local/lib to /etc/ld.so.conf, then run
> ldconfig(8).  That way /usr/local/lib will be permanently added to the
> dynamic linker search path.
>  - Jon

I had this problem too when trying to run Monodevelop, but not monodoc.

I solved the Monodevelop problem by installing it in the same prefix as 
I installed mono, mcs and gtk-sharp.

I hope it helps.


Francisco Figueiredo Jr.
Membro Fundador do Projeto MonoBrasil - MonoBrasil Project Founder Member

"Science without religion is lame;
religion without science is blind."

                   ~ Albert Einstein