[Mono-list] running mono problem

Felix Natter fnatter@gmx.net
Sat, 31 Jul 2004 23:06:01 +0200

Israel Fdez Cabrera <israel@segurmatica.com> writes:

> Hi all, I'm using mono at work without problems, now I'm installing it on my 
> laptop to work at home. I download a lot of rpm mono depends on, one of the 
> is libgtkhtml3, well... all mono rpms got installed well but now I run 
> monodoc and I get an error:
> Unhandled Exception: System.DllNotFoundException: gtkhtml-3.0
> The exception is right, there is not such dll in my system, 

I had the same problem when using garnome-2.6.2 (It's a common problem, you can
find it on google).

This refers to a system library (.so), not a mono .dll file.
In my case a wrong path was set in 

Look at this file:
  <dllmap dll="gtkhtml-3.0" target="libgtkhtml-3.1.so.7"/>

and in my case the gtkhtml .so was in PREFIX/lib/libgtkhtml-3.1.so.10, so I
changed it to:
  <dllmap dll="gtkhtml-3.0" target="libgtkhtml-3.1.so.10"/>
and now it works.

> but the most 
> curious thing is that in my job's PC, where mono run well and monodoc too, 
> there is not gtkhtml-3.0 or similar... ???

Maybe monodoc uses gecko# on that system?

Felix Natter
I love secs... for programming