[Mono-list] still trying to get it to work

Erik Dasque edasque@ximian.com
Fri, 9 Jul 2004 10:42:48 -0400

What you want to do Mark is add the mono channel, not point it at a 
directory. Does RedCarpet list any channels for your distro (I hope it 
sees it as Suse, not JDS).


On Jul 9, 2004, at 7:35 AM, Mark Molenda wrote:

> Ok I am still trying to get all of the pieces functioning, I downloaded
> red-carpet for the suse installation ( I'm running SUN Java Desktop 2 )
> and got everything started per Novell instructions
> pointed red-carpet at the directory that had all of the unzipped rpm's
> from the full suse distribution of mono.  and when I run red-carpet it
> fails on a winlib dependency even though I have a working version of
> wine ( latest rpm version ).  I checked my system and yes it is there.
> I even tried to compile winelib from the tar source in case there was a
> version problem and it bombed saying it can't find a windef.h file
> during the configure stage.
> So red-carpet was a total failure.
> Here is what I get when I run an rpm -iv *rpm on the directory
> containing all of the rpm files (including
> wine-20040615-SuSELinux80.i386.rpm )
> error: failed dependencies:
>         cairo >= 0.1.22 is needed by mono-cairo-0.96-1.ximian.0.2
>         winelib >= 0.2 is needed by mono-winforms-0.96-1.ximian.0.2
> Since all cairo files should be in the directory ( I pulled the full 
> zip
> ) what's going on here?   Any help would be appreciated.
> Also if any of the developers of mono can tell me if any "stock" Linux
> distribution have all of the necessary non-mono rpm's or libraries
> already loaded it would be appreciated.  I'm ready to pony up the money
> to get this to work.
> -- 
> _______________________________________________
> Mono-list maillist  -  Mono-list@lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list