[OBORONA-SPAM] RE: Re[2]: [Mono-list] Is it possible to install and run Gtk# without a root privilegies?

Vadim B. Guzev Vadim B. Guzev" <vguzev@yandex.ru
Sun, 4 Jul 2004 01:36:39 +0400

Hello Daniel,

DM> Make sure you got the glue library copied over to your prefix too.
DM> libgtksharpglue.so

These libraries were installed to /home/vadim/mono/gs-1.0/lib
I tried to add them to LD_LIBRARY_PATH, but this didn't help... I still
get this error:

Unhandled Exception: System.DllNotFoundException: libgtk-win32-2.0-0.dll
in <0x00053> (wrapper managed-to-native) Gtk.Application:gtk_init (int&,intptr&)
in <0x00038> Gtk.Application:Init ()
in <0x00014> GtkTest:Main ()

I there anything else?

Best regards,
Vadim B. Guzev

DM> I can't remember if they changed gtk# to have multiple glue libraries or
DM> not.  So, there might be libglibglue.so, libgdkglue.so, and
DM> libgladeglue.so too. But I'm not sure.

DM> -----Original Message-----
DM> From: mono-list-admin@lists.ximian.com
DM> [mailto:mono-list-admin@lists.ximian.com] On Behalf Of Vadim B. Guzev
DM> Sent: Saturday, July 03, 2004 4:37 PM
DM> To: mono-list
DM> Subject: Re[2]: [Mono-list] Is it possible to install and run Gtk#
DM> without a root privilegies?

DM> Hello Daniel,

DM>> If you build Mono and GTK# from source tarballs, on the configure
DM>> line, set your prefix. ./configure --prefix=/home/danmorg/mono
DM>> So when you do, make, make install, it will put the stuff in
DM>> /home/danmorg/mono.

DM> Well. Actually I did the same(used prefixes), but the simplest
DM> application doesn't work for me... I installed mono from sources to the
DM> directory /home/vadim/mono/m-1.0/. After that I tried to install Gtk#
DM> from sources to /home/vadim/mono/gs-1.0 but on the installation phase it
DM> said that mono package wasn't installed on this system. Then I set up
DM> the environment variable
DM> PKG_CONFIG_PATH=/home/vadim/mono/m-1.0/lib/pkgconfig
DM> and everything compiled successfully.
DM> The problem that now I can compile any Gtk# programs, but I can't run
DM> them, as I get the folowing mistake:

DM> 8<------------------------------------------------
DM> [vadim@skif basic.and.gtk]$ mbas gtk.vb -r gtk-sharp
DM> --------
DM> --------
DM> Compilation succeeded
DM> [vadim@skif basic.and.gtk]$ mono gtk.exe
DM> Unhandled Exception: System.DllNotFoundException: libgtk-win32-2.0-0.dll
DM> in <0x00053> (wrapper managed-to-native) Gtk.Application:gtk_init
DM> (int&,intptr&) in <0x00038> Gtk.Application:Init () in <0x00014>
DM> GtkTest:Main ()
DM> 8<------------------------------------------------

DM> Any ideas?

DM> Best regards,
DM> Vadim B. Guzev
DM> http://u.pereslavl.ru/~vadim/MCSharp/

DM> _______________________________________________
DM> Mono-list maillist  -  Mono-list@lists.ximian.com
DM> http://lists.ximian.com/mailman/listinfo/mono-list

DM> _______________________________________________
DM> Mono-list maillist  -  Mono-list@lists.ximian.com
DM> http://lists.ximian.com/mailman/listinfo/mono-list